The Debian User Group in Vienna

Text archives Help


Re: [Debienna] USB Fehler


Chronological Thread 
  • From: Albert Dengg <albert AT fsfe.org>
  • To: debienna AT lists.debienna.at
  • Subject: Re: [Debienna] USB Fehler
  • Date: Tue, 3 Jan 2017 18:52:29 +0100

On Tue, Jan 03, 2017 at 05:27:22PM +0100, Harald Geyer wrote:
> Markus Raab writes:
> > Das Problem dürfte sein das die Festplatte zu lange braucht um zu
> > antworten. Das Problem tritt nicht auf, wenn man die Festplatte zuerst
> > mal 10sec starten lässt und erst dann per USB ansteckt.
>
> Dann verstehe ich aber jetzt nicht warum:
> > (auch rmmod xhci_hcd && modprobe xhci_hcd hat nichts gebracht)
>
> > Das erklärt auch warum es nur bei einer Festplatte auftritt, die
> > anderen dürften "schnell genug" sein.
> >
> > Ich hab es auch auf Englisch dokumentiert:
> >
> > http://markus-raab.org/Howtos/Hardware/usb_errors
>
> Ich denke, das sollte man im Kernel fixen. Weiß jetzt aber auch nicht
> welcher Treiber da genau verantwortlich ist.
die frage ist, ob sich das im kernel richtig fixen
laesst...grundsaetzlich gibts ja definierte timeouts in USB afaik.

treiber technisch tipp ich auf usb masstorage oder UAS.

fuer mich klingt das auf den ersten blick so als ob die bridge
zuerst die usb initilization anfaengt und dann mittendrinnen drauf
wartet das die platte selber mit ihrer initilization fertig wird,
was ja unterschiedlich lang dauern kann
(ich hatte sowas schon mal mit ner alten usb2 bridge bei der du auch
aufpassen musstest das du die platte zuerst an den strom haengst und
dann erst usb verbindest)

lg
albert

Attachment: signature.asc
Description: PGP signature




Archive powered by MHonArc 2.6.18.

Top of page