The Debian User Group in Vienna

Text archives Help


Re: [Debienna] Router ohne http...


Chronological Thread 
  • From: Sebastian Bachmann <me AT free-minds.net>
  • To: debienna AT lists.debienna.at
  • Subject: Re: [Debienna] Router ohne http...
  • Date: Fri, 11 Jul 2014 21:39:56 +0200
  • List-archive: <http://lists.debienna.at/pipermail/debienna/>
  • List-id: <debienna.lists.debienna.at>

also das mit der fragmentierung checkt er irgendwie.
ein ping -c 2 -s 1472 -D google.com
gibt mir zurück:
[1405106986.213698] From xxxxxxx.adsl.highway.telekom.at (xxxxxx) icmp_seq=1 Frag needed and DF set (mtu = 1484)

mache ich einen http request mit MTU1500 am laptop sehe ich das ICMP Fragmentation needed package am laptop ankommen und dort steht auch drin dass der nächste hop nur mtu 1484 kann.

nur danach geht nix weiter...

dem dhcp server kann man sagen er soll die client aus 1484 mtu setzen aber das checken zB Android Geräte nicht...
was ich nicht verstehe ist, dass es eh eigentlich alles automatisch gehen sollte aber es nicht tut?

lg

On 2014-07-11 20:53, David Schmitt wrote:
Re,

On 2014-07-11 20:51, Sebastian Bachmann wrote:
Hi,

Nachtrag: ein ifconfig wlan0 mtu 1412 auf meinem laptop zeigt erfolg:
sofort geht jedes HTTP paket durch...

Die frage ist jetzt halt, warum checkt der router das nicht?

kommen die icmp pakete zur meldung der unterschiedlichen MTUs durch?
Ein vergleich was dein router sendet und dein laptop bekommt wäre hier
vielleicht aufschlussreich.


Mfg DavidS
_______________________________________________
Debienna mailing list
Debienna AT lists.debienna.at
http://lists.debienna.at/mailman/listinfo/debienna




Archive powered by MHonArc 2.6.18.

Top of page